Slow Response time
Incident Report for MaestroLabs
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 19:57 UTC
Investigating
We are seeing slow response times and timeouts related to OpenAI API
Posted Mar 20, 2023 - 13:16 UTC
This incident affected: Outlook Add-In.