Some TeamsMaestro bots are joining late

Incident Report for MaestroLabs

Resolved

This incident has been resolved.
Posted Sep 07, 2026 - 10:51 UTC

Monitoring

We identified the issue and deployed a fix.
We are monitoring the situation
Posted Sep 07, 2026 - 10:09 UTC

Investigating

We are seeing some TM bots joining bots later. We are investigating the issues and working on a mitigation
Posted Sep 07, 2026 - 08:56 UTC
This incident affected: TeamsMaestro.