Slow Response time
Incident Report for MaestroLabs
Resolved
Response times are back to normal
Posted Sep 06, 2023 - 19:13 UTC
Monitoring
Response times have normalized and we keep monitoring
Posted Sep 06, 2023 - 17:42 UTC
Identified
We have identified the issue and are working on a fix
Posted Sep 06, 2023 - 17:33 UTC
Investigating
We see slow response times for email generation.
We are currently investigating the issue.
Posted Sep 06, 2023 - 17:05 UTC
This incident affected: Outlook Add-In.